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Abstract

This final project aims to build a design for detecting ground altitude, air pressure, ambient temperature and monitoring the
health of climbers with body temperature parameters connected to Telegram based on the Arduino Mega 2560
microcontroller as the main controller. The BME280 sensor functions as a detector of ground level, air pressure and ambient
temperature on the ascent to be used as input by the system. Meanwhile, the MLX90614 is used as a body temperature
detector for climbers. After all input values have been read by the system, the LCD will display the results of the readings in
the form of text. The button functions as a giver of orders to start body temperature readings and send notifications of sensor
readings to the Telegram application. When a climber's temperature is detected to be more than or equal to 36 degrees
Celsius, the climber is in a safe body temperature range marked by the green LED indicator on, whereas when the climber's
temperature is less than 36 degrees Celsius, the red LED is active and the buzzer sounds indicating the climber is
hypothermic. From the results of the research conducted, it was found that this system can work with sensor values that will
be displayed on the LCD and for monitoring the climber's health it must be affordable with an adequate internet connection to
send Telegram notifications.
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Abstrak

Proyek akhir ini bertujuan untuk membangun sebuah rancangan sebagai pendeteksian ketinggian tanah, tekanan udara suhu
lingkungan serta monitoring kesehatan pendaki dengan parameter suhu tubuh yang terkoneksi dengan Telegram berbasis
mikrokontroller Arduino Mega 2560 sebagai pengontrol utamanya. Sensor BME280 berfungsi sebagai pendeteksi ketinggian
tanah , tekanan udara dan suhu lingkungan pada pendakian untuk dijadikan input oleh sistem. Sedangkan MLX90614
digunakan sebagai pendeteksi suhu tubuh dari pendaki. Setelah semua nilai input telah terbaca oleh sistem maka LCD akan
menampilkan hasil dari pembacaan berupa text. Button berfungsi sebagai pemberi perintah untuk memulai pembacaan suhu
tubuh dan mengirim notifikasi pembacaan sensor ke aplikasi Telegram. Ketika suhu pendaki terdeteksi lebih dari atau sama
dengan 36 derajat celsius maka pendaki berada di range suhu tubuh aman ditandai dengan indikator LED Hijau hidup,
sedangkan ketika suhu pendaki kurang dari 36 derajat celsius maka LED Merah aktif dan Buzzer bebunyi menandakan
pendaki terkena hipotermia. Dari hasil penelitian yang dilakukan, didapat bahwa sistem ini dapat bekerja dengan nilai sensor
yang akan ditampilkan pada LCD dan untuk monitoring kesehatan pendaki harus terjangkau dengan koneksi internet yang
memadai untuk terkirim ke notifikasi Telegram.

Kata kunci : Arduino Mega 2560, NodeMCU 8266, BME280 , MLX90614, LCD, LED, Buzzer. (oo) R

1. Pendahuluan

Seiring dengan perkembangan zaman dan teknologi
kebutuhan informasi yang cepat sangat dibutuhkan
dalam berbagai bidang, baik pertanian, perindustrian,
maupun stasiun meteorologi sehingga bisa menunjang
kinerja bidang tersebut. Salah satunya adalah informasi
profil vertikal atmosfer. Informasi itu meliputi
ketinggian, temperatur, kelembapan, tekanan, arah
angin, kecepatan angin, lintang dan bujur (Pratama,
2020).

Ketinggian, tekanan udara, dan temperatur udara
merupakan besaran-besaran yang biasa digunakan
ketika sedang beraktivitas di alam. Tekanan dan
temperatur udara biasa dimanfaatkan sebagai indikator
cuaca (Yurika, 2021). Gunung memiliki karakter
ketinggian yang variatif, sehingga membuat suhu di
gunung menentukan karakter suhu tubuh seseorang,
resiko yang paling sering menyerang para pendaki
gunung adalah hipotermi. Pendaki gunung dan
hipotermi merupakan sebuah hubungan yang sangat
terkait dalam pendakian. Kondisi tubuh yang terlalu
lama kedinginan, khususnya dalam cuaca berangin dan
hujan, dapat menyebabkan mekanisme pemanasan
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tubuh terganggu (Susilowati, 2020). Pemantauan dan
pengukuran suhu tubuh merupakan kegiatan yang
sangat penting dalam dunia kesehatan untuk
mengetahui  kondisi seseorang (Cahyadi, 2021).
Sebagian besar penyakit atau kematian terkait suhu
paparan lingkungan dapat dicegah tetapi seringkali
didahului oleh piliha Yang tidak tepat oleh korban atau
terlambatnya pelaporan pasien (Cahyadi, 2021). Maka
dari itu penting untuk mengetahui kesehatan kita saat
pendakian gunung.

Berdasarkan masalah diatas maka penulis ingin
membuat suatu alat yang dapat mendeteksi,
memonitoring, mengontrol, dan memberikan informasi
ketinggian tanah, tekanan udara dan suhu pada
pegunungan serta monitoring kesehatan pendaki. Untuk
mengatasi permasalahan tersebut, maka penulis ingin
membuat sebuah sistem dalam bentuk tugas akhir yang
berjudul “RANCANG BANGUN PENDETEKSI
KETINGGIAN TANAH, TEKANAN UDARA DAN
SUHU SERTA MONITORING KESEHATAN
PENDAKI DALAM PENDAKIAN GUNUNG
DENGAN NOTIFIKASI TELEGRAM BERBASIS
ARDUINO MEGA 2560”.

2. Metodologi Penelitian

Penelitian ini menggunakan metode penelitian

pengembangan (Research and Development atau R&D).

Research and Development adalah metode penelitian
yang digunakan untuk menghasilkan produk tertentu,
dan menguji keefektifan produk tersebut. Penelitian
pengembangan dibidang pendidikan merupakan suatu
jenis penelitian yang bertujuan untuk menghasilkan
produk-produk untuk kepentingan
pendidikan/pembelajaran (Aswardi, 2019). Adapun
kerangka kerja dari penelitian ini dapat disajikan pada
gambar 1 dibawah ini.

Identifikasi
Masalah

Pengumpulan
Data

»  Analisis Alat

Pembuatan Alat

Pengujian Alat Perancangan Alat

Implementasi

Gambar 1. Konsep Metode penelitian

2.1 Identifikasi masalah

Di dalam penelitian ini, permasalahan yang
dijadikan potensi pada sistem ini, yaitu proses
pendakian gunung yang di kategorikan sebagai salah

satu olahraga berat yang sangat membutuhkan
informasi seperti suhu, tekanan udara, dan ketinggian
tanah dan juga informasi tubuh pendaki yang rentan
terkena hipotermia dalam pendakian gunung. Oleh
karena itu di butuhkan sebuah sistem pendekteksi suhu,
tekanan udara, ketinggian tanah, dan monitoring
kesehatan pada pendaki untuk dapat mengambil
keputusan dalam pendakian gunung.

2.2 Pengumpulan Data

Berdasarkan metode yang dilakukan pada saat
proses penelitian untuk memperoleh data yang akurat
dan juga dalam pembuatan alat untuk mendapatkan
hasil yang optimal, maka penulis menggunakan
beberapa metode dalam pengumpulan data yang akan
digunakan dalam perancangan dan pengembangan
sistem tersebut adalah penelitian kepustakaan,
penelitian laboratorium dan penelitian lapangan.

2.3 Analisis Sistem

Pemanfaatan microcontroller Arduino Mega 2560
sebagai pendali sistem, pengguanaan Sensor BME280
untuk mendeteksi tekanan udara, suhu, ketinggian
tanah, dan sensor suhu MLX90614 sebagai sensor suhu
yang akan memonitor kondisi kesehatan pendaki,
NodeMCU ESP8266 untuk mengirim informasi dalam
bentuk notifikasi Telegram, dan LCD digunakan
sebagai output yang menampilkan informasi dalam
bentuk text, serta LED merah digunakan sebagai
indikator apabila kesehatan pendaki tidak baik dan
LED hijau digunakan sebagai indikator apabila
kesehatan pendaki baik, terakhir ada Buzzer sebagai
indikator yang berbunyi apabila kondisi kesehatan
pendaki tidak baik.

2.4 Perancangan Sistem

Dalam memudahkan desain dan perancangan
sistem, digunakan Context Diagram, Block Diagram,
Data Flow Diagram, Flowchart, dan Desain Sistem,
agar sistem yang dibuat jelas dan sesuai perencanaan.

2.5 Pembuatan Sistem

Pembuatan sistem didasari oleh tahapan-tahapan
sebelumnya dari identifikasi masalah, pengumpulan
data, Analisa data , dan beberapa pertimbangan-
pertimbangan yang telah disebutkan pada perancangan
sistem sebelumnya seperti context diagram, data flow
diagram, blok diagram, flowchart, dan desain kemudian
semua komponen utama seperti Arduino Mega
2560,Sensor BME280, Sensor MLX90614, NodeMCU
ESP8266, LCD, LED, dan Buzzer, dan komponen
pendukung seperti saklar dan kapasitor yang akan
dirangkai lalu membuat kerangka alat dari akrilik
kemudian menginput program keseluruhan
menggunakan aplikasi Arduino IDE.
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2.6 Pengujian Sistem

Dalam pengujian software, dilakukan terhadap
program yang telah dibuat berdasarkan perancangan
software sebelumnya, yaitu program yang dibuat
menggunakan bahasa pemrograman C Arduino IDE.
Sedangkan dalam pengujian hardware, pengujian
dilakukan terhadap kinerja fisik alat yang telah
dirancang apakah fisik alat yang telah dibuat dapat
diimplementasikan nantinya, termasuk pengujian
komponen-komponen sistem yang ada di dalamnya.

Dalam pengujian sistem secara keseluruhan,
sistem dijalankan dengan keadaan hardware dan
software yang sudah dikombinasikan sehingga sistem
yang kompleks terbentuk. Pengujian dilakukan dengan
menjalankan  sistem dengan mempertimbangkan
perancangan sistem sebelumnya sebagai acuan, dimana
sistem diuji sebagai alat yang dapat dikendalikan
dengan pintar.

2.7 TImplementasi

Implementasi merupakan rangkaian kegiatan yang
di lakukan setelah perancangan sistem dengan tujuan
yang ingin di capai dan dapat di operasikannya
rancangan yang telah di buat (Dwi Wijonarko, 2019).
Dengan beresikonya pendakian gunung tentu perlu
sebuah system untuk mengetahui kondisi lingkungan
serta kondisi pendaki agar agar pengambilan keputusan
dalam pendakian dapat diambil dengan cepat.
Pengimplementsian alat ini dapat diimplementasikan
oleh pendaki dalam pendakian gunung.

3. Hasil dan Pembahasan

3.1 Pengujian Rangkaian Sistem Minimum

Adapun langkah yang harus dilalui
pemrograman Arduino adalah sebagai berikut :

dalam

1) Jalankan IDE Arduino dengan mengklik ikon
aplikasi arduino.exe, sehingga aplikasi akan
terbuka dan menampilkan halaman seperti gambar 2.

Gambar 2. Tampilan Arduino IDE

2) Kemudian buat program baru dengan memilih
menu File > New sehingga muncul tampilan seperti
gambar 3. dan dapat membuat program sesuai
dengan yang diperlukan.

@ sketch_jan30a | Arduino 187 -
Eile| Edit_Sketch Tools Help

CuleN

0

New
Open..
Open Recent
Sketchbook
Examples.
Close W
Save s,
SaveAs.  ClsShitsS

e, to run repeatedly:
Curt Shift+P.
Print Cculep.

nces  Ctrl+ Comma

Quit i

Gambar 3. Tampilan New edit program

3) Ketika program, kemudian simpan pada folder yang
diinginkan dengan memilih menu File > Save
seperti gambar 4. dibawah ini.

@ 281 Arduino 187
File Edit Sketch Tools Help
Ctrl+N
cuo

Close W
Ctriss
Ctrl+Shift+S

up  Ctrl ShiftsP

Gambar 4. Tampilan Save program

4) Setelah itu compile program yang telah dibuat
dengan memilih menu Sketch > Verivy/Compile
seperti gambar 5.

)mm

Gambar 5. Tampilan Compile program

5) Langkah selanjutnya yaitu mengupload file program
yang telah dibuat dan di kompilasi tersebut kedalam
board Arduino yang digunakan sebagai kontroler
dari sistem yang dipakai.

6) Pertama-tama pasanglah kabel USB Printer ke
Arduino dan ke komputer atau laptop yang
digunakan.
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7) Kemudian pilih menu Sketch > Upload (Ctrl + U
untuk cara lebih cepat) seperti gambar 6.

- o x

¢ CilsShift-U _

i
Cri-At+s

Gambar 6. Tampilan Upload Program

8) Jika program sukses di upload ke dalam Arduino,
maka akan muncul tulisan “Done Uploading”,
seperti gambar 7. maka Arduino siap untuk
digunakan.

Gambar 7. Tampilan Upload program selesai
3.2 Pengujian Sensor BME280

Hasil pengujian sensor BME280 nilainya akan

No. Sensor Tampilan Notifikasi
MLX90614 LCD 20x4 Telegram
1. Mendeteksi Aktif Aktif
Suhu Tubuh >=
36 °C Notifikasi nilai
suhu,
Notifikisai
“pendaki tidak
mengalami
hipotermia”
2. Mendeteksi Aktif Aktif
Suhu Tubuh <
36 °C Notifikasi nilai
suhu,
Notifikisai
“pendaki
mengalami
hipotermia”

setelah pengujian
Dengan demikian, pengujian sistem keseluruhan dapat
dijalankan melalui langkah-langkah berikut ini:

ditampilkan pada LCD 20x4. Berikut dibawah ini hasil 1)

dari pengujian sensor BME280 yang dilakukan:

NO. Sensor BME280 Tampilan LCD 20x4
1. Mendeteksi Aktif
Ketinggian Tanah,
Suhu, Tekanan
Udara

Tabel 1. Hasil Pembacaan Sensor 280
3.3 Pengujian Sensor MLX90614

Pengujian Sensor Suhu MLX90614 nilainya akan
ditampilkan pada LCD 20x4 dan notifikasi Telegram.
Berikut dibawah ini hasil dari pengujian sensor
BME280 yang dilakukan:

2)

Tabel 2 Hasil Pembacaan Sensor

3.4 Pengujian Sistem Keseluruhan

Pengujian alat secara keseluruhan dapat dilakukan
sistem permodul diselesaikan.

Sistem alat dalam kondisi tidak aktif, jika kabel
power tidak dihubungkan ke sumber tegangan
arus listrik dari baterai Gambar 8 berikut ini.

Gambar 8. Tampilan ketika sistem aktif.

Sistem alat aktif setelah kabel power dihubungkan
ke sumber tegangan arus listrik, LCD 20x4 akan
menampilkan suhu lingkungan, tekanan udara,
ketinggian tanah serta menampilkan hasil
pengukuran suhu tubuh pendaki, seperti gambar 9
berikut ini.
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Gambar 9. Sistem Alat Aktif

3) Hasil pengujian pendeteksian ketinggian tanah,
tekanan udara dan suhu dapat dilihat pada LCD

20x4 seperti gambar 10 berikut ini.

Gambar 10. Tampilan Nilai Ketinggian Tanah,
Tekanan Udara dan Suhu

4) Hasil pengujian pengukuran suhu tubuh pendaki
dapat dilihat pada LCD 20x4 seperti gambar 11
berikut ini.

Gambar 11. Tampilan Suhu tubuh pendaki

5) Aktifkan hotspot portabel pada smartphone android
untuk menghungkan NodeMCU ESP8266 ke
koneksi jaringan internet.

6) Tekan Button sebagai trigger untuk mengirim
informasi kesehatan pendaki ke notifikasi Telegram
seperti gambar 12 berikut ini.

Gambar 12. Menekan Button

7) Buka aplikasi Telegram pada Smartpohe android.
Setelah itu, klik bot telegram yang telah dibuat
dengan username "SKRIPSI JERRY" untuk melihat
hasil dari informasi kesehatan pendaki seperti
gambar 13 berikut ini.

09.33 a1 @ @ W @

< @ SKRIPSI JERRY

/start go.zz oo

Gambar 13. Tampilan Bot Telegram

8) Informasi kondisi kesehatan pendaki akan muncul
pada aplikasi Telegram dengan username
"SKRIPSI JERRY" seperti Gambar 14 berikut ini.

- EEE) S<RIPSI JERRY

/start ooaa o

Gambar 14. Tampilan Informasi Kesehatan
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4. Kesimpulan dan Saran

Adapun hasil dari rancang bangun sistem pendeteksi
ketinggian tanah, tekanan udara dan suhu serta
monitoring kesehatan pada pendaki dalam pendakian
gunung dengan notifikasi Telegram berbasis Arduino
Mega 2560 ini dapat disimpulkan sebagai berikut:

1. Dengan adanya sensor BME280, sensor suhu
MLX90614, dan Internet of Things (IoT) melalui Node
MCU ESP8266 dengan memanfaatkan media wireless
dan terhubung dengan Arduino Mega 2560
menggunakan serial komunikasi, hal ini sangat
membantu dalam mendeteksi ketinggian tanah, tekanan
udara, dan suhu serta pelaporan informasi kesehatan
pendaki yang notifikasinya akan dikirim ke aplikasi
Telegram agar orang-orang pada pos pendakian dapat
mengetahui kondisi kesehatan pendaki pada saat
pendakian.

2. Proses pendeteksian ketinggian tanah, tekanan udara,
dan suhu lingkungan dengan sensor BME280 serta
monitoring kesehatan pendaki pada saat aktivitas
pendakian gunung dengan parameter suhu tubuh
dengan memanfaatkan sensor MLX90614 yang
mampu mengukur nilai suhu tubuh Pendaki yang akan
dijadikan sebagai acuan apakah pendaki mengalami
hipotermia atau tidak.

3. Sistem mampu melakukan pendeteksian ketinggian
tanah, tekanan udara dan suhu lingkungan dengan
memanfaatkan  sensor BME280 dan mampu
memberikan informasi kesehatan dengan parameter
suhu tubuh dengan memanfaatkan sensor suhu
MLX90614 yang mana nilainya akan timbul pada LCD
20x4 yang akan menjadi informasi penting bagi
pendaki dalam mengambilan keputusan pendakian.

Berdasarkan hasil penelitian dan pembahasan
serta kesimpulan yang telah dikemukakan, berikut
adalah beberapa saran yang diharapkan dapat menjadi
masukan dan bahan pertimbangan:

1. Perlunya pengembangan sistem yang lebih
kompleks seperti informasi lokasi pendaki gunung atau
tambahan fitur lainnya.

2. Proses monitoring kesehatan pendaki dengan
parameter suhu tubuh sangat efektif terutama pada
jangkauan jarak pembacaan suhu 5 cm sampai dengan
10 cm.

3. Untuk mempercepat respon dari aplikasi
telegram untuk sistem pendeteksi ketinggian tanah,
tekanan udara dan suhu serta monitoring kesehatan
pada pendaki dalam pendakian gunung, maka
diperlukannya pancaran sinyal yang kuat dan memiliki
kecepatan transfer data yang baik.
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